The Point-to-Point Tunneling Protocol (PPTP) is a method for implementing virtual private networks. PPTP uses a control channel over TCP and a GRE tunnel operating to encapsulate PPP packets. The PPTP specification does not describe encryption or authentication features and relies on the PPP protocol being tunneled to implement security functionality. However the most common PPTP implementation, shipping with the Microsoft Windows product families, implements various levels of authentication and encryption natively as standard features of the Windows PPTP stack. The intended use of this protocol is to provide similar levels of security and remote access as typical VPN products.
by Wikipedia
The configuration is the following
ROUTER-A
username <user 1> password <password 1>
username <user 2> password <password 2>
!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pptp
virtual-template 1
!
interface Virtual-Template1
ip unnumbered Vlan1
peer default ip address pool PPTP-Pool
no keepalive
ppp encrypt mppe auto
ppp authentication ms-chap ms-chap-v2
!
interface ATM0
no ip address
load-interval 30
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0.1 point-to-point
description *** Link Data For ADSL ***
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
interface Vlan1
description ***Private IP for LAN***
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
ip policy route-map PBR
!
interface Dialer1
description ***Bandwidth For DATA***
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
no cdp enable
no ppp chap wait
ppp pap sent-username XXXXUSERD password 7 XXXXPWD
no ppp pap wait
!
ip local pool PPTP-Pool 10.10.10.10 10.10.10.20
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip nat inside source list 100 interface Dialer1 overload
!
access-list 100 remark ***ACL NAT ON VC DATA***
access-list 100 permit ip 10.10.10.0 0.0.0.255 any
No hay comentarios:
Publicar un comentario